wolfcub3223
wolfcub3223

Member

Member Since: 28th Jan 2007
Total posts: 128
Posted:i got LED poi and a week after one of them just started flickering and nor its got just an extreamly low glow that i can bearly see ive replaced batterys and evry thing and its not working i didnt do anything to break it. i just dont get it angry

Ich brauche Zeit
Kein Heroin kein Alkohol kein Nikotin
Brauch keine Hilfe
Kein Koffein
Doch Dynamit und Terpentin
Ich brauche l fr Gasolin
Explosiv wie Kerosin
Mit viel Oktan und frei von Blei
Einen Kraftstoff wie Benzin

Delete Topic

Neser
Neser

member
Location: North Queensland
Member Since: 27th Dec 2005
Total posts: 63
Posted:So, replacing batteries doesnt work?



Check the connections. Sometimes theres not enough current passing from the batteries to the LEDs. My glow staff plays up sometimes after doing throws and a slight tap generally fixes it. In the poi, I have had to pull them apart and readjust them, may need a bit of solder or the battery compartment is a bit loose.



Alternatively, contact the place of purchase and they may fix/replace it.



~ Neser


Fuel your fascination, burn your desire and dance with flames

Delete


Similar Topics

Using the keywords [broke] we found the following similar topics.
1. Forums > The attachment ring broke [2 replies]
2. Forums > TuTu broke his fire cherry this weekend =) [6 replies]
3. Forums > I broke my wookie... [14 replies]
4. Forums > pfffft....I think I broke it [1 reply]
5. Forums > i think iv broke me back! - shoulder reels [11 replies]

     Show more..