• All Purchases made this month instantly go into the draw to win a USD $ 100.00 credit to your HoP account.
 

Forums > Help! > Why won't my brand new LED poi work?

Login/Join to Participate

3rd Half
SILVER Member since Jun 2010

3rd Half

stranger
Location: Virginia

Total posts: 2
Posted:I just received my poi order in the mail today and excitedly opened the package. Along with other gear, I bought LED Sock Poi. I removed the tab separating the batteries and tried to turn it on. . .to no avail. I tried replacing the batteries, made sure they were all facing the right way, even put in new batteries that were just out of the package. When I put in the new batteries, they flickered on just once and then didn't work. I'm a complete idiot when it comes to circuit boards, so please explain what I'm doing wrong in as simple way as possible.

Delete Topic

hopnell


stranger


Total posts: 5
Posted:Hello 3rd Half! I've emailed you some more detailed instructions, but for the benefit of anyone else having this issue, please try holding the on/off button down for a few seconds and it should switch on. This delayed switch feature is to avoid the balls turning on during transit while being knocked around. Hope that helps :-)

Delete

3rd Half
SILVER Member since Jun 2010

3rd Half

stranger
Location: Virginia

Total posts: 2
Posted:Holding down the button worked. Thank you C:

Delete

FireTom


Stargazer


Total posts: 6650
Posted:ah, hopnell welcome to HoP wave I missed your entre hug

the best smiles are the ones you lead to wink

Delete