• All Purchases made this month instantly go into the draw to win a USD $ 100.00 credit to your HoP account.
 

Forums > Help! > Windows XP "files write protection" hassle

Login/Join to Participate

FireTom


Stargazer


Total posts: 6650
Posted:WinXP is bugging again mad2 censored

I did a stupid thing and deleted a "desktop.ini" file in my foto files rolleyes I don't know whether this is coincidence, but since then all my folders are "write protected"...

I deflag it in the "folders properties" and hit "apply for all subfolders"... it keeps bouncing back.

How to undo this? Any ideas greatly appreciated hug


the best smiles are the ones you lead to wink

Delete Topic

Bubbles_
SILVER Member since Nov 2004

Bubbles_

Carpal \'Tunnel
Location: mancunian

Total posts: 3383
Posted:is it just the files or the folders that are write protected? for the folders its normal...

are you sure its not the files...


Disclaimer:im not responsible for what i say or do whether it be before,during and after drinking alcoholic substances (owned by BMVC).
Creater of Jenisms(TM)
Virginity like bubble,one prick all gone.

Delete

FireTom


Stargazer


Total posts: 6650
Posted:Well it's folders and subfolders... all the way. And unfortunately it's not normal, because I set them to be not write protected.

I still can delete files and rename them, but if I am changing the viewing options it changes them back (which is the nuisance)... However I dislike my computer to overrule my settings - for obvious reasons. I already searched Google, but it doesn't return with an "easy to understand" procedure... frown

Thanks for taking a look into it and to share your thoughts smile


the best smiles are the ones you lead to wink

Delete

Rouge Dragon
BRONZE Member since Jul 2003

Rouge Dragon

Insert Champagne Here
Location: without class distinction

Total posts: 13215
Posted:could be worse...you could have Vista wink

i would have changed ***** to phallus, and claire to petey Petey

Rougie: but that's what I'm doing here
Arnwyn: what letting me adjust myself in your room?..don't you dare quote that on HoP...

Delete

FireTom


Stargazer


Total posts: 6650
Posted:ubblol You show the kind of attitude I like...

the best smiles are the ones you lead to wink

Delete

polarity
SILVER Member since May 2005

polarity

veteran
Location: on the wrong planet

Total posts: 1228
Posted:If you delete files like desktop.ini or thumbs.db, then any changes you make after that will be cached in memory, and will be lost if the computer is reset. XP doesn't have the sense to make them again if you change the settings.



You should be able to copy a desktop.ini into the folder from somewhere else, then change the settings and have them stick.



Also, there used to be a lot of settings in desktop.ini, but all the visual ones got moved into the registry, so it's likely you've come up against the limit for the number of folders that can have their visual settings stored there (about 1000). You can make the limit bigger, but it also makes the registry bigger, and uses more memory.



"apply to all subfolders" has never worked properly for windows because of this, which is annoying, because big collections of pictures need a lot of folders to have the right view settings.



The second item on this page increases the limit for you (although if you have a huge number of folders it still may not be enough).


You aren't thinking or really existing unless you're willing to risk even your own sanity in the judgment of your existence.

Green peppers, lime pickle and whole-grain mustard = best sandwich filling.

Delete

FireTom


Stargazer


Total posts: 6650
Posted:That's very bad news... It might even only have been a "thumbs.db" - not even a "desktop.ini"

I found two folders without a "thumbs" file, copied from elsewhere and pasted it in them... Problem prevails.

Do I need to buy a new computer now? (sigh) rolleyes

Or re-install XP? eek I rather buy a new PC...


the best smiles are the ones you lead to wink

Delete

Yakumo
SILVER Member since May 2006

Yakumo

veteran
Location: Oxfordshire

Total posts: 1237
Posted:thumbs.db is nothing but a little data cache of the image or video thumbnails generated when you view a folder in icon or thumbnail mode.



it is always recreated if it's been removed, when you cause thumbs to be generated again (simply by viewing the folder in icon or thumbnail mode)





When you do properties on a single folder, you will see 'read only' to be the filled in cube, this does not mean it's read only, or write, but changing it to ticked, or blank, gives you the prompt for making the changes to the folder only, or all subfolders and files.



check the properties on the folder again, and it will be the filled in square again.



This is the same on all XP systems, don't worry about it, full reasoning behind this can be read on http://support.microsoft.com/kb/326549


Blinded by Hyperlights, please donate generously grin

Delete

FireTom


Stargazer


Total posts: 6650
Posted:I have different partitions on my harddrive
c - for all programs
d - my disc-drive
e - to have some buffer, if c is getting too big. In the meantime I store some temporary files there
f - all my files, music, pictures and the like
g - another reserve, where I export files to (for say) burn a DVD

All files - on every partition - appears to be "write protected" without me having done that. If I (for say) change the view of my folders to "cascade", or "tiles" - my computer does it. But it turns back to the original (details) view, by the time I turn my back on it....

Pretty annoying.

Scanned for viruses and spyware a few times - no result.

I am changing properties, de-flag the folders (un-write protect), the system asks me whether I want to include all subfolders and files - yes - moment please - dadada nice little useless animation - and then it looks fine... until I return and ask again. frown ubbloco


the best smiles are the ones you lead to wink

Delete

mech
BRONZE Member since Jun 2003

mech

Carpal \'Tunnel
Location: "In your ear"

Total posts: 6207
Posted:*GEEKS ALL OF YOU GEEKS!*

wanders back to his IT job.....

wink


Step (el-nombrie)

Delete

Yakumo
SILVER Member since May 2006

Yakumo

veteran
Location: Oxfordshire

Total posts: 1237
Posted:just to double check , when your examining the readonly status you are checking on a couple of individual files? not folders right? as, as stated above, when doing properties on a folder, it will _always_ be displayed as the filled in cube, not empty or ticked.

If it's bunches of files that are constantly resetting themselves, and you definitely have security rights to alter their status, then this isn't activity I've seen before, so,
if your antivirus is uptodate and checks for spyware etc too, then you could always do a scan with sysinternals rootkit revealer.

there are ways of fully restoring all file permission and security settings, but they're really quite drastic, I wouldn't recommend them here.


Blinded by Hyperlights, please donate generously grin

Delete

FireTom


Stargazer


Total posts: 6650
Posted:Nono... misunderstanding, but thanks heeps for even bothering to read this. hug

Now:

IExplorer - drive "F:\own documents" - rightklick: Properties

It shows me the properties and at the bottom the box "read only" ("write protected" in German translation) is filled grey and has a flag. I click it and un-check it (box is white, no flag). "Apply" (or "OK") - then it asks me whether I want to change the attribution for ALL subfolders and files - YES (pleeease) ... Then comes this (useless) "progress" animation and it's done. NICE.

Now I rightclick on "F:\own documents" again and the box is grey and flagged mad2 ubbloco

I have AVG (updated) and scanned ten times since the problem occurred first time... *bangs computer against wall*


the best smiles are the ones you lead to wink

Delete

Yakumo
SILVER Member since May 2006

Yakumo

veteran
Location: Oxfordshire

Total posts: 1237
Posted:yes, that is exactly what I stated in my first post smile That is the way winXP works.



when you do properties on a folder it will always be the filled in box, no matter what you do.



it is a tri state tickbox, empty or ticked or filled.

But in this case the ticked or empty stats you only see after you've just touched it before applying, and then viewing again.



you can change it to trigger the folder only, or all files and subfolders, but when u come back to look at it again it'll be displayed back as the filled in state, always.



This is by design see http://support.microsoft.com/kb/326549

(quick summary, NTFS folders don't actually store read-only state, it only actually applies to files)



if you view file properties though it will work as you'd expect (ticked for read only, blank for write enabled, and grey(filled) if multiple files selected with varying states) and using the 'apply to all subfolders and files' option will correctly change all files.



If you were used to this acting differently, under XP, on other machines, then I can only surmise that the partition you were using was still FAT32.


Blinded by Hyperlights, please donate generously grin

Delete

FireTom


Stargazer


Total posts: 6650
Posted:*Raises eyebrow, turns to Mr. Spock's voice: Fascinating*



But YAY you are extremely double right bounce



So far FAT32... changed my two externals to NTFS, only one "Big Mama" remained FAT and is waiting for her turn to diet...



hug my saviour ubblove



Decorated Space Commander!!!!!

EDITED_BY: FireTom (1181082635)


the best smiles are the ones you lead to wink

Delete

Posted:Windows XP has a bug where sometimes it won't let you write to or move files, because it thinks a program is using the file even if it isn't.



I don't know if this is what is causing your problem, but you could try some of these work arounds:



- Rename, move or copy the files somewhere else

- Restart the computer in safe mode and see if that helps

- Open Word (or something similar), file>open, you get that window that lets you open things. Typically you have more control from this window, you might be able to move the files if you can't from windows explorer.


Delete

Yakumo
SILVER Member since May 2006

Yakumo

veteran
Location: Oxfordshire

Total posts: 1237
Posted:PsyRush - it's all sorted now if you read the last few posts smile

and as for locked files, it's because the explorer shell tends to keep the handle open on files sometimes, especially if they're files that explorer generates thumbnails for. or sometimes it's because the program, or a process it's spawned you may not be aware of, hasn't actually terminated successfully.

you can either hunt down the handle and terminate the offending process with process explorer from sysinternals, or you can use tools that do the whole thing for you, including deleting the file if you wish, when you right click it, such as unlocker, both of these applications are free.
Sysinternals were bought up by MS a few months ago for providing excellent tools, fortunately they've kept them all free also.


Blinded by Hyperlights, please donate generously grin

Delete

polarity
SILVER Member since May 2005

polarity

veteran
Location: on the wrong planet

Total posts: 1228
Posted:I think I'll stick with kill and chmod biggrin

You aren't thinking or really existing unless you're willing to risk even your own sanity in the judgment of your existence.

Green peppers, lime pickle and whole-grain mustard = best sandwich filling.

Delete

FireTom


Stargazer


Total posts: 6650
Posted:Psy Rush - yupp all resolved...

Thanks all of you - it has been easier than apprehended (sigh). hug

Let's go outside and play smile


the best smiles are the ones you lead to wink

Delete


Similar Topics

Using the keywords [window* xp file* write protection hassle] we found the following similar topics.
1. Forums > Windows XP files write protection hassle [17 replies]
2. Learn > Hoop > Mini hoop > tunring window *help/resource
3. Learn > Accidents > Fire Accidents > FIRE POI accident *help/resource t one hundred percent sure what to write in this article about my accident ...
4. Forums > Best Windows OS? [16 replies]
5. Forums > XP USERS ONLY!!! I NEED HELP! [8 replies]

     Show more..