Forums > Technical Discussion > metal parts burning on fire poi

Login/Join to Participate

_Poiboy_PLATINUM Member
bastard child of satan
1,113 posts
Location: Raanana, Israel


Posted:
something that happened to me at my last burn, after lighting the poi and waiting for the fire to spread across the wicks, the flames from the top wick almost reached the handles, when I started spinning I noticed that the chain was on fire... I put it out by swinging and kept spinning... when I watched the vid I noticed some of the metal parts were burning too...

can anyone tell me why did that happen?? (I'm using the #13 SS ball chain from this site... I might've dipped it in paraffin but I still don't think it should catch fire after spraying off the fuel)

SkulduggeryGOLD Member
Pirate Pixie Crew Captain
8,428 posts
Location: Wales


Posted:
Ball chain has a hollow part in the middle of the chains. If the chains were submerged in fuel there could well be some inside the balls in the chain, even when you have spun off the fuel before lighting the heads. Try not to dip your chains in the fuel as you dip the heads. Hook them up out of the fuel container.

Feed me Chocolate!!! Feed me NOW!


ImmortalAngelSILVER Member
Scientist!
578 posts
Location: Waterloo, Ontario, Canada


Posted:
I have had the same thing happen to me a few times with my ball chains. Skulduggery got it on the nose as to why it happens and how to prevent it.
when I dip my wicks I dip to just above the top of the wick, and just a bit onto the top of the tube core. I never had a problem once I started doing that.

Educate your self in the Hazards of Fire Breathing <img src="/ubbthreads/images/graemlins/smile.gif" alt="" /> STAY SAFE! <img src="/ubbthreads/images/graemlins/hug.gif" alt="" />


HOP Newsletter
Sign up to get the latest on sales, new releases and more...